Разработка электроники,

Систем автоматики,

Программного обеспечения

8(981)186-50-82

ООО "Антех ПСБ",
Санкт-Петербург

anteh@bk.ru

antehru@gmail.com

©

FreeBSD 9.2 обновление портов. Проблемы curl-7.43.0_1 openssl-1.0.2_3

https://anteh.ru

Если видим такое:

...
===>>> Continuing initial dependency check for devel/cmake
===>>> Launching child to install ftp/curl

===>>> Checking dependent ports >> subversion-1.8.13 >> apr-1.5.1.1.5.4 >> mysql55-client-5.5.42 >> cmake-3.1.3 >> ftp/curl (40/40)

===>>> Port directory: /usr/ports/ftp/curl

===>>> This port is marked IGNORE
===>>> GSSAPI_BASE is set, which is not compatible with OpenSSL/LibreSSL from ports. Set GSSAPI_NONE or do not use ports SSL.


===>>> If you are sure you can build it, remove the
IGNORE line in the Makefile and try again.

===>>> Update for ftp/curl failed
===>>> Aborting update

===>>> Update for cmake-3.1.3 failed
===>>> Aborting update

===>>> Update for mysql55-client-5.5.42 failed
===>>> Aborting update

===>>> Update for apr-1.5.1.1.5.4 failed
===>>> Aborting update

===>>> Update for subversion-1.8.13 failed
===>>> Aborting update

===>>> Update for portdowngrade-1.5 failed
===>>> Aborting update

то:
curl-7.43.0_1
# cd /usr/ports/ftp/curl
# make config

и убираем опции
[ ] CA_BUNDLE Install CA bundle for OpenSSL
[ ] TLS_SRP TLS-SRP (Secure Remote Password) support
( ) OPENSSL SSL/TLS support via OpenSSL

openssl-1.0.2_3
# cd /usr/ports/security/openssl
# make config
проверяем, чтобы было
[x] SHARED build of shared libs

И дальше всё пойдёт

КСИП-16 V1.0 КСИП-16 V2.0 КСИП-20 V1.0

Copyright ©Новиков Алексей Александрович,

2012-2017 Санкт-Петербург, 197372, ООО "Антех ПСБ",

anteh собака bk.ru